# CVE-2023-31544: alkacon-OpenCMS vulnerable to stored Cross-site Scripting

> Attackers can execute arbitrary scripts via stored XSS in the Title field of the Upload Image module in OpenCMS.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2023
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-m44f-9jhg-59cr

## What is CVE-2023-31544?

CVE-2023-31544 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in alkacon-OpenCMS v11.0.0.0 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Title field under the Upload Image module.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-31544?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |
| `org.opencms:opencms-core` | Maven | All versions | 11.0.1 |

Products: Alkacon Opencms.

## How do I fix CVE-2023-31544?

Upgrade org.opencms:opencms-core to 11.0.1 or later.

## Is CVE-2023-31544 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31544 exists.

## Other vulnerabilities in n/a

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31544 and fix it if it is affected.

What it is: CVE-2023-31544 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31544 exists.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1
- org.opencms:opencms-core (Maven): affected all versions; fixed in 11.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31544/ (Markdown: https://insights.sbomify.com/CVE-2023-31544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31544
- OSV: https://osv.dev/vulnerability/CVE-2023-31544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31544/
Summaries are generated and may contain mistakes; the official description above is the record.
