# CVE-2023-31579: Dromara Lamp-Cloud Use of Hard-coded Cryptographic Key

> Attackers can authenticate to the application by crafting JWT tokens using a hardcoded cryptographic key, leading to unauthorized access.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-xr8c-mq5x-5f56

## What is CVE-2023-31579?

CVE-2023-31579 is a critical vulnerability in n/a, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dromara Lamp-Cloud before v3.8.1 was discovered to use a hardcoded cryptographic key when creating and verifying a Json Web Token. This vulnerability allows attackers to authenticate to the application via a crafted JWT token.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2023-31579?

4 open source packages ship an affected version, including top.tangyh.basic:lamp-core and top.tangyh.basic:lamp-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `top.tangyh.basic:lamp-core` | Maven | All versions | 3.8.1 |
| `top.tangyh.basic:lamp-core` | Maven | All versions | 3.8.1 |
| `top.tangyh.basic:lamp-util` | Maven | All versions | 3.8.1 |
| `top.tangyh.basic:lamp-util` | Maven | All versions | 3.8.1 |

Products: Tangyh Lamp-Cloud.

## How do I fix CVE-2023-31579?

Upgrade top.tangyh.basic:lamp-core to 3.8.1 or later.

## Is CVE-2023-31579 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31579 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31579 and fix it if it is affected.

What it is: CVE-2023-31579 is a critical vulnerability in n/a, published on 2 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31579 exists.

Affected packages and fixed versions:
- top.tangyh.basic:lamp-core (Maven): affected all versions; fixed in 3.8.1
- top.tangyh.basic:lamp-core (Maven): affected all versions; fixed in 3.8.1
- top.tangyh.basic:lamp-util (Maven): affected all versions; fixed in 3.8.1
- top.tangyh.basic:lamp-util (Maven): affected all versions; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31579/ (Markdown: https://insights.sbomify.com/CVE-2023-31579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31579
- OSV: https://osv.dev/vulnerability/CVE-2023-31579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31579/
Summaries are generated and may contain mistakes; the official description above is the record.
