# CVE-2023-31606: RedCloth Regular Expression Denial of Service issue

> Attackers can cause a Denial of Service in applications using the redcloth gem by supplying crafted payloads to the sanitize_html function.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2023
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-31606, DLA-3480-1, GHSA-qcm3-vfq5-wfr2, MGASA-2023-0291, UBUNTU-CVE-2023-31606, USN-6358-1

## What is CVE-2023-31606?

CVE-2023-31606 is a high-severity denial of service vulnerability in n/a, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Regular Expression Denial of Service (ReDoS) issue was discovered in the sanitize_html function of redcloth gem v4.0.0. This vulnerability allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-31606?

2 open source packages ship an affected version, including RedCloth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `RedCloth` | RubyGems | All versions | 4.3.3 |
| `RedCloth` | RubyGems | All versions | 4.3.3 |

Products: Promptworks Redcloth.

## How do I fix CVE-2023-31606?

Upgrade RedCloth to 4.3.3 or later.

## Is CVE-2023-31606 being exploited?

There is no known exploitation of CVE-2023-31606 in the wild and no public exploit code.

Public exploit code:

- https://github.com/merbinr/CVE-2023-31606 (github_poc): https://github.com/merbinr/CVE-2023-31606

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31606 and fix it if it is affected.

What it is: CVE-2023-31606 is a high-severity denial of service vulnerability in n/a, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-31606 in the wild and no public exploit code.

Affected packages and fixed versions:
- RedCloth (RubyGems): affected all versions; fixed in 4.3.3
- RedCloth (RubyGems): affected all versions; fixed in 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31606/ (Markdown: https://insights.sbomify.com/CVE-2023-31606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31606
- OSV: https://osv.dev/vulnerability/CVE-2023-31606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31606/
Summaries are generated and may contain mistakes; the official description above is the record.
