# CVE-2023-3192: Session Fixation in froxlor/froxlor

> Attackers can hijack user sessions in Froxlor, leading to unauthorized account access and control.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-jr66-9ghf-6gp3

## What is CVE-2023-3192?

CVE-2023-3192 is a medium-severity vulnerability in froxlor/froxlor, published on 11 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Session Fixation in GitHub repository froxlor/froxlor prior to 2.1.0.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-3192?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.1.0 |
| `froxlor/froxlor` | Packagist | All versions | 2.1.0 |

Products: Froxlor Froxlor.

## How do I fix CVE-2023-3192?

Upgrade froxlor/froxlor to 2.1.0 or later.

## Is CVE-2023-3192 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3192 exists.

## Other vulnerabilities in froxlor/froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3192 and fix it if it is affected.

What it is: CVE-2023-3192 is a medium-severity vulnerability in froxlor/froxlor, published on 11 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3192 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.0
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3192/ (Markdown: https://insights.sbomify.com/CVE-2023-3192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3192
- OSV: https://osv.dev/vulnerability/CVE-2023-3192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3192/
Summaries are generated and may contain mistakes; the official description above is the record.
