# CVE-2023-3193: Liferay Portal and Liferay DXP Vulnerable to XSS via the Layout Module

> Remote attackers can inject arbitrary web script or HTML via a specific parameter in the Layout module's SEO configuration.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jun 2023
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-qxf6-mp24-52cv

## What is CVE-2023-3193?

CVE-2023-3193 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Layout module's SEO configuration in Liferay Portal 7.4.3.70 through 7.4.3.73, and Liferay DXP 7.4 update 70 through 73 allows remote attackers to inject arbitrary web script or HTML via the `_com_liferay_layout_admin_web_portlet_GroupPagesPortlet_backURL` parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-3193?

4 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.13.u70 to 7.4.13.u73 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.13.u70 to 7.4.13.u73 | None |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.3.70-ga70 | 7.4.3.74-ga74 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.3.70-ga70 | 7.4.3.74-ga74 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2023-3193?

Apply the vendor's patch.

## Is CVE-2023-3193 being exploited?

There is no known exploitation of CVE-2023-3193 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3193 and fix it if it is affected.

What it is: CVE-2023-3193 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-3193 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.13.u70 up to 7.4.13.u73; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.13.u70 up to 7.4.13.u73; no fix listed
- com.liferay.portal:release.portal.bom (Maven): affected from 7.4.3.70-ga70; fixed in 7.4.3.74-ga74
- com.liferay.portal:release.portal.bom (Maven): affected from 7.4.3.70-ga70; fixed in 7.4.3.74-ga74

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3193/ (Markdown: https://insights.sbomify.com/CVE-2023-3193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3193
- OSV: https://osv.dev/vulnerability/CVE-2023-3193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3193/
Summaries are generated and may contain mistakes; the official description above is the record.
