# CVE-2023-31999: @fastify/oauth2 vulnerable to Cross Site Request Forgery due to reused Oauth2 state

> An attacker can bypass CSRF protections in the @fastify/oauth2 library due to a static state parameter, potentially allowing unauthorized actions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jul 2023
- **Updated:** 26 Nov 2024
- **Also known as:** CVE-2023-35935, GHSA-g8x5-p9qc-cf95

## What is CVE-2023-31999?

CVE-2023-31999 is a high-severity vulnerability in npm @fastify/oauth2, published on 4 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

All versions of @fastify/oauth2 used a statically generated state parameter at startup time and were used across all requests for all users. The purpose of the Oauth2 state parameter is to prevent Cross-Site-Request-Forgery attacks. As such, it should be unique per user and should be connected to the user's session in some way that will allow the server to validate it.

v7.2.0 changes the default behavior to store the state in a cookie with the http-only and same-site=lax attributes set. The state is now by default generated for every user. Note that this contains a breaking change in the checkStateFunction function, which now accepts the full Request object.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-31999?

2 open source packages ship an affected version, including @fastify/oauth2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/oauth2` | npm | All versions | 7.2.0 |
| `@fastify/oauth2` | npm | All versions | 7.2.0 |

Products: Fastify Oauth2.

## How do I fix CVE-2023-31999?

Upgrade @fastify/oauth2 to 7.2.0 or later.

## Is CVE-2023-31999 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31999 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-31999 and fix it if it is affected.

What it is: CVE-2023-31999 is a high-severity vulnerability in npm @fastify/oauth2, published on 4 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-31999 exists.

Affected packages and fixed versions:
- @fastify/oauth2 (npm): affected all versions; fixed in 7.2.0
- @fastify/oauth2 (npm): affected all versions; fixed in 7.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-31999/ (Markdown: https://insights.sbomify.com/CVE-2023-31999/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-31999
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-31999
- OSV: https://osv.dev/vulnerability/CVE-2023-31999

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-31999/
Summaries are generated and may contain mistakes; the official description above is the record.
