# CVE-2023-32004: Path traversal in Node

> Attackers can bypass file permission checks in Node.js experimental permission model to access unauthorized files via path traversal.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2023
- **Updated:** 8 May 2025
- **Also known as:** BIT-node-2023-32004, BIT-node-min-2023-32004, GHSA-x3wm-m4vj-p6px

## What is CVE-2023-32004?

CVE-2023-32004 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 15 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been discovered in Node.js version 20, specifically within the experimental permission model. This flaw relates to improper handling of Buffers in file system APIs causing a traversal path to bypass when verifying file permissions.

This vulnerability affects all users using the experimental permission model in Node.js 20.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-32004?

2 open source packages ship an affected version, including node and node-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.5.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.5.1 |

Products: Fedoraproject Fedora, Nodejs Node.js.

## How do I fix CVE-2023-32004?

Upgrade node to 20.5.1 or later.

## Is CVE-2023-32004 being exploited?

There is no known exploitation of CVE-2023-32004 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32004 and fix it if it is affected.

What it is: CVE-2023-32004 is a high-severity path traversal vulnerability in Fedoraproject Fedora, published on 15 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32004 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.5.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32004/ (Markdown: https://insights.sbomify.com/CVE-2023-32004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32004
- OSV: https://osv.dev/vulnerability/CVE-2023-32004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32004/
Summaries are generated and may contain mistakes; the official description above is the record.
