# CVE-2023-32005: Information disclosure in Node

> Attackers can bypass file read restrictions to obtain metadata from unauthorized files when using the experimental permission model with specific flags.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2023
- **Updated:** 5 May 2025
- **Also known as:** BIT-node-2023-32005, BIT-node-min-2023-32005, GHSA-6hjf-ffg5-v8w7

## What is CVE-2023-32005?

CVE-2023-32005 is a medium-severity vulnerability in Nodejs Node.js, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been identified in Node.js version 20, affecting users of the experimental permission model when the --allow-fs-read flag is used with a non-* argument.

This flaw arises from an inadequate permission model that fails to restrict file stats through the `fs.statfs` API. As a result, malicious actors can retrieve stats from files that they do not have explicit read access to.

This vulnerability affects all users using the experimental permission model in Node.js 20.

Please note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2023-32005?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 20.0.0 | 20.5.1 |
| `node-min` | Bitnami | From 20.0.0 | 20.5.1 |

Products: Nodejs Node.js.

## How do I fix CVE-2023-32005?

Upgrade node to 20.5.1 or later.

## Is CVE-2023-32005 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32005 exists.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32005 and fix it if it is affected.

What it is: CVE-2023-32005 is a medium-severity vulnerability in Nodejs Node.js, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32005 exists.

Affected packages and fixed versions:
- node (Bitnami): affected from 20.0.0; fixed in 20.5.1
- node-min (Bitnami): affected from 20.0.0; fixed in 20.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32005/ (Markdown: https://insights.sbomify.com/CVE-2023-32005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32005
- OSV: https://osv.dev/vulnerability/CVE-2023-32005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32005/
Summaries are generated and may contain mistakes; the official description above is the record.
