CVE-2023-32007 Apache Spark: Shell command injection via Spark UI
Attackers can execute arbitrary shell commands via Spark UI impersonation when ACLs are enabled, requiring an upgrade to a supported version.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-32007?
CVE-2023-32007 is a high-severity command injection vulnerability in Apache Spark, published on 2 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected.
NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Users are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.
Weakness: CWE-77
Which versions are affected by CVE-2023-32007?
6 open source packages ship an affected version, including org.apache.spark:spark-parent_2.12, spark and pyspark. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.spark:spark-parent_2.12 Maven | From 3.1.1 | 3.2.2 |
org.apache.spark:spark-parent_2.12 Maven | From 3.1.1 | 3.2.2 |
spark Bitnami | All versions | 3.0.4, 3.1.4, 3.2.2 |
pyspark PyPI | All versions | 3.2.2 |
pyspark PyPI | From 3.1.1 | 3.2.2 |
pyspark PyPI | From 3.1.1 | 3.2.2 |
Products include Apache Spark.
How do I fix CVE-2023-32007?
Upgrade org.apache.spark:spark-parent_2.12 to 3.2.2 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2023-32007 being exploited?
There is no known exploitation of CVE-2023-32007 in the wild and no public exploit code.
Other vulnerabilities in Apache Spark
Sources
Also known as BIT-spark-2023-32007, GHSA-59hw-j9g6-mfg3, PYSEC-2023-72.