{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.spark:spark-parent_2.12, spark and pyspark. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32007 in the wild and no public exploit code.","fix":"Upgrade org.apache.spark:spark-parent_2.12 to 3.2.2 or later.","what":"CVE-2023-32007 is a high-severity command injection vulnerability in Apache Spark, published on 2 May 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32007 and fix it if it is affected.\n\nWhat it is: CVE-2023-32007 is a high-severity command injection vulnerability in Apache Spark, published on 2 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32007 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.spark:spark-parent_2.12 (Maven): affected from 3.1.1; fixed in 3.2.2\n- org.apache.spark:spark-parent_2.12 (Maven): affected from 3.1.1; fixed in 3.2.2\n- spark (Bitnami): affected all versions; fixed in 3.0.4, 3.1.4, 3.2.2\n- pyspark (PyPI): affected all versions; fixed in 3.2.2\n- pyspark (PyPI): affected from 3.1.1; fixed in 3.2.2\n- pyspark (PyPI): affected from 3.1.1; fixed in 3.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32007/ (Markdown: https://insights.sbomify.com/CVE-2023-32007/index.md)","id":"CVE-2023-32007","markdown":"https://insights.sbomify.com/CVE-2023-32007/index.md","name":"CVE-2023-32007","record":{"aliases":["BIT-spark-2023-32007","GHSA-59hw-j9g6-mfg3","PYSEC-2023-72"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Spark","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary shell commands via Spark UI impersonation when ACLs are enabled, requiring an upgrade to a supported version.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"spark","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected.\n\nNOTE: This vulnerability only affects products that are no longer supported by the maintainer.\n\nUsers are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.","ecosystems":["Bitnami","Maven","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Spark: Shell command injection via Spark UI","id":"CVE-2023-32007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":6,"n_references":4,"next":{"headline":"Windows Resilient File System (ReFS) Remote Code Execution Vulnerability","id":"CVE-2023-32008"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.4","3.1.4","3.2.2"],"introduced":["0","3.1.1","3.2.0"],"last_affected":[],"package":"spark","purl":"pkg:bitnami/spark","source":"BIT-spark-2023-32007"},{"ecosystem":"Maven","fixed":["3.2.2"],"introduced":["3.1.1"],"last_affected":[],"package":"org.apache.spark:spark-parent_2.12","purl":null,"source":"GHSA-59hw-j9g6-mfg3"},{"ecosystem":"Maven","fixed":["3.2.2"],"introduced":["3.1.1"],"last_affected":[],"package":"org.apache.spark:spark-parent_2.12","purl":"pkg:maven/org.apache.spark/spark-parent_2.12","source":"GHSA-59hw-j9g6-mfg3"},{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["0"],"last_affected":[],"package":"pyspark","purl":"pkg:pypi/pyspark","source":"PYSEC-2023-72"},{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["3.1.1"],"last_affected":[],"package":"pyspark","purl":null,"source":"GHSA-59hw-j9g6-mfg3"},{"ecosystem":"PyPI","fixed":["3.2.2"],"introduced":["3.1.1"],"last_affected":[],"package":"pyspark","purl":"pkg:pypi/pyspark","source":"GHSA-59hw-j9g6-mfg3"}],"prev":{"headline":"Security feature bypass in Node","id":"CVE-2023-32006"},"products":["Apache Spark"],"published":"2023-05-02","related":[{"cvss_score":8.8,"headline":"Apache Spark Command Injection","id":"CVE-2022-33891","kev_date_added":"2023-03-07","published":"2022-07-18"},{"cvss_score":9.8,"headline":"Improper Authentication in Apache Spark","id":"CVE-2020-9480","kev_date_added":null,"published":"2020-06-23"},{"cvss_score":9.8,"headline":"Remote Code Execution in spark-core","id":"CVE-2018-17190","kev_date_added":null,"published":"2018-11-19"},{"cvss_score":9.1,"headline":"HTTP Request Smuggling in Netty","id":"CVE-2019-20445","kev_date_added":null,"published":"2020-01-29"},{"cvss_score":8.8,"headline":"Apache Spark: Spark History Server Code Execution Vulnerability","id":"CVE-2025-54920","kev_date_added":null,"published":"2026-03-14"},{"cvss_score":7.8,"headline":"Apache Spark Deserialization of Untrusted Data vulnerability","id":"CVE-2017-12612","kev_date_added":null,"published":"2017-09-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary shell commands via Spark UI impersonation when ACLs are enabled, requiring an upgrade to a supported version.","url":"https://insights.sbomify.com/CVE-2023-32007/"}