# CVE-2023-3204: Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update

> Authenticated subscribers can modify arbitrary site options due to missing authorization checks in the Materialis WordPress theme.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jun 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-m9j5-qh5w-4336

## What is CVE-2023-3204?

CVE-2023-3204 is a medium-severity missing authorization vulnerability in extendthemes Materialis, published on 20 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Materialis theme for WordPress is vulnerable to limited arbitrary options updates in versions up to, and including, 1.1.24. This is due to missing authorization checks on the companion_disable_popup() function called via an AJAX action. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to modify any option on the site to a numerical value.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-3204?

It affects 1 product.


Products: Extendthemes Materialis.

## How do I fix CVE-2023-3204?

No fix has been published for CVE-2023-3204 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-3204 being exploited?

There is no known exploitation of CVE-2023-3204 in the wild and no public exploit code.

## Other vulnerabilities in extendthemes Materialis

- [CVE-2019-25142](https://insights.sbomify.com/CVE-2019-25142/): Mesmerize <= 1.6.89 & Materialis <= 1.0.172 - Authenticated Arbitrary Options Update (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3204 and fix it if it is affected.

What it is: CVE-2023-3204 is a medium-severity missing authorization vulnerability in extendthemes Materialis, published on 20 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3204 in the wild and no public exploit code.

Affected product: extendthemes Materialis. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3204/ (Markdown: https://insights.sbomify.com/CVE-2023-3204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3204
- OSV: https://osv.dev/vulnerability/CVE-2023-3204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3204/
Summaries are generated and may contain mistakes; the official description above is the record.
