CVE-2023-3205 Inefficient Regular Expression Complexity in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a denial of service in GitLab by importing or cloning malicious content due to inefficient regular expression complexity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3205?

CVE-2023-3205 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 1 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab affecting all versions starting from 15.11 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. An authenticated user could trigger a denial of service when importing or cloning malicious content.

Weakness: CWE-1333

Which versions are affected by CVE-2023-3205?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.016.1.5, 16.2.5, 16.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3205?

Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-3205 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3205 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3205, GHSA-8gh5-v944-cphh, UBUNTU-CVE-2023-3205.

Is CVE-2023-3205 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free