# CVE-2023-32058: Vyper vulnerable to integer overflow in loop

> An integer overflow in Vyper loop variables allows attackers to manipulate contract logic, potentially leading to unauthorized code execution in smart contracts.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2023
- **Updated:** 24 Jan 2025
- **Also known as:** GHSA-6r8q-pfpv-7cgj, PYSEC-2023-78

## What is CVE-2023-32058?

CVE-2023-32058 is a high-severity vulnerability in vyperlang vyper, published on 11 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, due to missing overflow check for loop variables, by assigning the iterator of a loop to a variable, it is possible to overflow the type of the latter. The issue seems to happen only in loops of type `for i in range(a, a + N)` as in loops of type `for i in range(start, stop)` and `for i in range(stop)`, the compiler is able to raise a `TypeMismatch` when trying to overflow the variable. The problem has been patched in version 0.3.8.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-32058?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-32058?

Upgrade vyper to 0.3.8 or later.

## Is CVE-2023-32058 being exploited?

There is no known exploitation of CVE-2023-32058 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32058 and fix it if it is affected.

What it is: CVE-2023-32058 is a high-severity vulnerability in vyperlang vyper, published on 11 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32058 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32058/ (Markdown: https://insights.sbomify.com/CVE-2023-32058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32058
- OSV: https://osv.dev/vulnerability/CVE-2023-32058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32058/
Summaries are generated and may contain mistakes; the official description above is the record.
