# CVE-2023-32070: Improper Neutralization of Script in Attributes in XWiki (X)HTML renderers

> Attackers can execute arbitrary scripts in XWiki via malicious attributes, potentially leading to session hijacking or data theft.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 May 2023
- **Updated:** 27 Jan 2025
- **Also known as:** GHSA-6gf5-c898-7rxp

## What is CVE-2023-32070?

CVE-2023-32070 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 10 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-83 (Improper Neutralization of Script in Attributes in a Web Page)

## Which versions are affected by CVE-2023-32070?

14 open source packages ship an affected version, including org.xwiki.platform:xwiki-core-rendering-api, org.xwiki.platform:xwiki-platform-annotation-core and org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-core-rendering-api` | Maven | All versions to 3.0-milestone-2 | None |
| `org.xwiki.platform:xwiki-core-rendering-api` | Maven | All versions to 3.0-milestone-2 | None |
| `org.xwiki.platform:xwiki-platform-annotation-core` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.platform:xwiki-platform-annotation-core` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-html` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-html` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-html5` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-html5` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-xhtml` | Maven | All versions | 14.6-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-syntax-xhtml` | Maven | All versions | 14.6-rc-1 |

Products: Xwiki Rendering, Xwiki Xwiki.

## How do I fix CVE-2023-32070?

Upgrade to a fixed version.

## Is CVE-2023-32070 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32070 exists.

Public exploit code:

- https://github.com/shoucheng3/xwiki__xwiki-rendering_CVE-2023-32070_14-5 (github_poc): https://github.com/shoucheng3/xwiki__xwiki-rendering_CVE-2023-32070_14-5

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32070 and fix it if it is affected.

What it is: CVE-2023-32070 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 10 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32070 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-core-rendering-api (Maven): affected all versions up to 3.0-milestone-2; no fix listed
- org.xwiki.platform:xwiki-core-rendering-api (Maven): affected all versions up to 3.0-milestone-2; no fix listed
- org.xwiki.platform:xwiki-platform-annotation-core (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.platform:xwiki-platform-annotation-core (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5 (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5 (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-html (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-html (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-html5 (Maven): affected all versions; fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-html5 (Maven): affected all versions; fixed in 14.6-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32070/ (Markdown: https://insights.sbomify.com/CVE-2023-32070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32070
- OSV: https://osv.dev/vulnerability/CVE-2023-32070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32070/
Summaries are generated and may contain mistakes; the official description above is the record.
