# CVE-2023-32071: XWiki Platform vulnerable to RXSS via editor parameter - importinline template

> Attackers can execute arbitrary JavaScript in victim browsers via a crafted URL, potentially leading to account takeover.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2023
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-j9h5-vcgv-2jfm

## What is CVE-2023-32071?

CVE-2023-32071 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 9 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform. Starting in versions 2.2-milestone-1 and prior to versions 14.4.8, 14.10.4, and 15.0-rc-1, it's possible to execute javascript with the right of any user by leading him to a special URL on the wiki targeting a page which contains an attachment. This has been patched in XWiki 15.0-rc-1, 14.10.4, and 14.4.8. The easiest possible workaround is to edit file `<xwiki app>/templates/importinline.vm` and apply the modification described in commit 28905f7f518cc6f21ea61fe37e9e1ed97ef36f01.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2023-32071?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-distribution-war. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.5 | 14.10.4 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 14.5 | 14.10.4 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 2.2-milestone-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 2.2-milestone-1 | 14.4.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-32071?

Upgrade org.xwiki.platform:xwiki-platform-distribution-war to a fixed version for your release line: 14.10.4 or 14.4.8.

## Is CVE-2023-32071 being exploited?

There is no known exploitation of CVE-2023-32071 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32071 and fix it if it is affected.

What it is: CVE-2023-32071 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 9 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32071 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.5; fixed in 14.10.4
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 14.5; fixed in 14.10.4
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 2.2-milestone-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 2.2-milestone-1; fixed in 14.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32071/ (Markdown: https://insights.sbomify.com/CVE-2023-32071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32071
- OSV: https://osv.dev/vulnerability/CVE-2023-32071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32071/
Summaries are generated and may contain mistakes; the official description above is the record.
