# CVE-2023-32077: Netmaker has Hardcoded DNS Secret Key

> Hardcoded DNS secret key allows unauthenticated users to access DNS API endpoints in Netmaker, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-8x8h-hcq8-jwwx, GO-2023-2022

## What is CVE-2023-32077?

CVE-2023-32077 is a high-severity vulnerability in gravitl netmaker, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netmaker makes networks with WireGuard. Prior to versions 0.17.1 and 0.18.6, hardcoded DNS key usage has been found in Netmaker allowing unauth users to interact with DNS API endpoints. The issue is patched in 0.17.1 and fixed in 0.18.6.  If users are using 0.17.1, they should run `docker pull gravitl/netmaker:v0.17.1` and `docker-compose up -d`. This will switch them to the patched users. If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. As a workaround, someone who is using version 0.17.1 can pull the latest docker image of the backend and restart the server.

Weakness: CWE-798 (Use of Hard-coded Credentials), CWE-321 (Use of Hard-coded Cryptographic Key)

## Which versions are affected by CVE-2023-32077?

5 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gravitl/netmaker` | Go | All versions | 0.17.1, 0.18.6 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.17.1 |
| `github.com/gravitl/netmaker` | Go | All versions | 0.17.1 |
| `github.com/gravitl/netmaker` | Go | From 0.18.0 | 0.18.6 |
| `github.com/gravitl/netmaker` | Go | From 0.18.0 | 0.18.6 |

Products: Netmaker Netmaker.

## How do I fix CVE-2023-32077?

Upgrade github.com/gravitl/netmaker to a fixed version for your release line: 0.17.1 or 0.18.6.

## Is CVE-2023-32077 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32077 exists.

Public exploit code:

- Netmaker - Hardcoded DNS Secret Key (nuclei): http/cves/2023/CVE-2023-32077.yaml

## Other vulnerabilities in gravitl netmaker

- [CVE-2023-32079](https://insights.sbomify.com/CVE-2023-32079/): Netmaker Privilige Escalation Vulnerability (high 8.8)
- [CVE-2022-36110](https://insights.sbomify.com/CVE-2022-36110/): Netmaker vulnerable to Insufficient Granularity of Access Control (high 8.8)
- [CVE-2022-0664](https://insights.sbomify.com/CVE-2022-0664/): Use of Hard-coded Cryptographic Key in gravitl/netmaker (high 8.8)
- [CVE-2026-29771](https://insights.sbomify.com/CVE-2026-29771/): Netmaker: Denial of Service via Server Shutdown Endpoint (high 8.7)
- [CVE-2026-38651](https://insights.sbomify.com/CVE-2026-38651/): Netmaker does not verify JWT signatures for host tokens (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32077 and fix it if it is affected.

What it is: CVE-2023-32077 is a high-severity vulnerability in gravitl netmaker, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32077 exists.

Affected packages and fixed versions:
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.17.1, 0.18.6
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.17.1
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 0.17.1
- github.com/gravitl/netmaker (Go): affected from 0.18.0; fixed in 0.18.6
- github.com/gravitl/netmaker (Go): affected from 0.18.0; fixed in 0.18.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32077/ (Markdown: https://insights.sbomify.com/CVE-2023-32077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32077
- OSV: https://osv.dev/vulnerability/CVE-2023-32077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32077/
Summaries are generated and may contain mistakes; the official description above is the record.
