CVE-2023-32078 Netmaker IDOR Vulnerability Allows User to Update Other User's Password
Attackers can update other users' passwords via IDOR in Netmaker, leading to account takeover; upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-32078?
CVE-2023-32078 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 24 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netmaker makes networks with WireGuard. An Insecure Direct Object Reference (IDOR) vulnerability was found in versions prior to 0.17.1 and 0.18.6 in the user update function. By specifying another user's username, it was possible to update the other user's password. The issue is patched in 0.17.1 and fixed in 0.18.6. If Users are using 0.17.1, they should run `docker pull gravitl/netmaker:v0.17.1` and `docker-compose up -d`. This will switch them to the patched users. If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. As a workaround, someone using version 0.17.1 can pull the latest docker image of the backend and restart the server.
Weakness: CWE-639
Which versions are affected by CVE-2023-32078?
5 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/gravitl/netmaker Go | All versions | 0.17.1, 0.18.6 |
github.com/gravitl/netmaker Go | All versions | 0.17.1 |
github.com/gravitl/netmaker Go | All versions | 0.17.1 |
github.com/gravitl/netmaker Go | From 0.18.0 | 0.18.6 |
github.com/gravitl/netmaker Go | From 0.18.0 | 0.18.6 |
Products include Netmaker Netmaker.
How do I fix CVE-2023-32078?
Upgrade github.com/gravitl/netmaker to a fixed version for your release line: 0.17.1 or 0.18.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-32078 being exploited?
There is no known exploitation of CVE-2023-32078 in the wild and no public exploit code.
Other vulnerabilities in gravitl netmaker
- CVE-2023-32079 Netmaker Privilige Escalation Vulnerability
- CVE-2022-36110 Netmaker vulnerable to Insufficient Granularity of Access Control
- CVE-2022-0664 Use of Hard-coded Cryptographic Key in gravitl/netmaker
- CVE-2026-29771 Netmaker: Denial of Service via Server Shutdown Endpoint
- CVE-2026-38651 Netmaker does not verify JWT signatures for host tokens
Sources
Also known as GHSA-256m-j5qw-38f4, GO-2023-2023.