CVE-2023-32080 Wings vulnerable to escape to host from installation container
Attackers can escape the installation container to execute code on the host system by manipulating install scripts or user-supplied data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-32080?
CVE-2023-32080 is a critical vulnerability in pterodactyl wings, published on 10 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Wings is the server control plane for Pterodactyl Panel. A vulnerability affecting versions prior to 1.7.5 and versions 1.11.0 prior to 1.11.6 impacts anyone running the affected versions of Wings. This vulnerability can be used to gain access to the host system running Wings if a user is able to modify an server's install script or the install script executes code supplied by the user (either through environment variables, or commands that execute commands based off of user data). This vulnerability has been resolved in version `v1.11.6` of Wings, and has been back-ported to the 1.7 release series in `v1.7.5`. Anyone running `v1.11.x` should upgrade to `v1.11.6` and anyone running `v1.7.x` should upgrade to `v1.7.5`.
There are no workarounds aside from upgrading. Running Wings with a rootless container runtime may mitigate the severity of any attacks, however the majority of users are using container runtimes that run as root as per the Wings documentation. SELinux may prevent attackers from performing certain operations against the host system, however privileged containers have a lot of freedom even on systems with SELinux enabled.
It should be noted that this was a known attack vector, for attackers to easily exploit this attack it would require compromising an administrator account on a Panel. However, certain eggs (the data structure that holds the install scripts that get passed to Wings) have an issue where they are unknowingly executing shell commands with escalated privileges provided by untrusted user data.
Weakness: CWE-250
Which versions are affected by CVE-2023-32080?
5 open source packages ship an affected version, including github.com/pterodactyl/wings. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/pterodactyl/wings Go | All versions | 1.7.5, 1.11.6 |
github.com/pterodactyl/wings Go | All versions | 1.7.5 |
github.com/pterodactyl/wings Go | All versions | 1.7.5 |
github.com/pterodactyl/wings Go | From 1.11.0 | 1.11.6 |
github.com/pterodactyl/wings Go | From 1.11.0 | 1.11.6 |
Products include Pterodactyl Wings.
How do I fix CVE-2023-32080?
Upgrade github.com/pterodactyl/wings to a fixed version for your release line: 1.7.5 or 1.11.6.
Is CVE-2023-32080 being exploited?
There is no known exploitation of CVE-2023-32080 in the wild and no public exploit code.
Other vulnerabilities in pterodactyl wings
- CVE-2024-27102 Improper isolation of server file access in github.com/pterodactyl/wings
- CVE-2023-25168 Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings
- CVE-2024-34066 Arbitrary File Write/Read in Pterodactyl wings
- CVE-2023-25152 Symbolic Link (Symlink) Following in github.com/pterodactyl/wings
- CVE-2025-69199 Pterodactyl websocket endpoints have no visible rate limits or monitoring, allowing for DOS attacks
Sources
Also known as GHSA-p744-4q6p-hvc2, GO-2023-1768.