# CVE-2023-32082: etcd key name can be accessed via LeaseTimeToLive API

> Attackers with limited permissions can read key names via the LeaseTimeToLive API in etcd clusters with authentication enabled.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2023
- **Updated:** 24 Jan 2025
- **Also known as:** AZL-26666, BIT-etcd-2023-32082, DEBIAN-CVE-2023-32082, GHSA-3p4g-rcw5-8298, UBUNTU-CVE-2023-32082

## What is CVE-2023-32082?

CVE-2023-32082 is a low-severity vulnerability in etcd-io etcd, published on 11 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

etcd is a distributed key-value store for the data of a distributed system. Prior to versions 3.4.26 and 3.5.9, the LeaseTimeToLive API allows access to key names (not value) associated to a lease when `Keys` parameter is true, even a user doesn't have read permission to the keys. The impact is limited to a cluster which enables auth (RBAC). Versions 3.4.26 and 3.5.9 fix this issue. There are no known workarounds.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-32082?

5 open source packages ship an affected version, including github.com/etcd-io/etcd and etcd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/etcd-io/etcd` | Go | All versions | 3.4.26 |
| `github.com/etcd-io/etcd` | Go | All versions | 3.4.26 |
| `github.com/etcd-io/etcd` | Go | From 3.5.0 | 3.5.9 |
| `github.com/etcd-io/etcd` | Go | From 3.5.0 | 3.5.9 |
| `etcd` | Bitnami | All versions | 3.4.26, 3.5.9 |

Products: Etcd Etcd.

## How do I fix CVE-2023-32082?

Upgrade github.com/etcd-io/etcd to a fixed version for your release line: 3.4.26 or 3.5.9.

## Is CVE-2023-32082 being exploited?

There is no known exploitation of CVE-2023-32082 in the wild and no public exploit code.

## Other vulnerabilities in etcd-io etcd

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32082 and fix it if it is affected.

What it is: CVE-2023-32082 is a low-severity vulnerability in etcd-io etcd, published on 11 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32082 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/etcd-io/etcd (Go): affected all versions; fixed in 3.4.26
- github.com/etcd-io/etcd (Go): affected all versions; fixed in 3.4.26
- github.com/etcd-io/etcd (Go): affected from 3.5.0; fixed in 3.5.9
- github.com/etcd-io/etcd (Go): affected from 3.5.0; fixed in 3.5.9
- etcd (Bitnami): affected all versions; fixed in 3.4.26, 3.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32082/ (Markdown: https://insights.sbomify.com/CVE-2023-32082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32082
- OSV: https://osv.dev/vulnerability/CVE-2023-32082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32082/
Summaries are generated and may contain mistakes; the official description above is the record.
