{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32184 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2023-32184 is a high-severity vulnerability in opensuse-welcome, published on 19 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32184 and fix it if it is affected.\n\nWhat it is: CVE-2023-32184 is a high-severity vulnerability in opensuse-welcome, published on 19 Sep 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32184 exists.\n\nAffected product: opensuse-welcome. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32184/ (Markdown: https://insights.sbomify.com/CVE-2023-32184/index.md)","id":"CVE-2023-32184","markdown":"https://insights.sbomify.com/CVE-2023-32184/index.md","name":"CVE-2023-32184","record":{"aliases":["GHSA-6cr9-4pv5-j99r","openSUSE-SU-2023:0219-1","openSUSE-SU-2023:0230-1","openSUSE-SU-2024:13126-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"openSUSE welcome app","requires_auth":"none","summary":"Local attackers can execute code as the user running opensuse-welcome if a custom layout is chosen due to insecure storage of sensitive information.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"welcome","vendor":"opensuse"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-922","name":"Insecure Storage of Sensitive Information"}],"description":"A Insecure Storage of Sensitive Information vulnerability in openSUSE opensuse-welcome allows local attackers to execute code as the user that runs opensuse-welcome if a custom layout is chosen\nThis issue affects opensuse-welcome: from 0.1 before 0.1.9+git.35.4b9444a.","ecosystems":["SUSE:Package Hub 15 SP4","SUSE:Package Hub 15 SP5","openSUSE:Leap 15.4","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Information disclosure in opensuse-welcome","id":"CVE-2023-32184","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":4,"n_references":1,"next":{"headline":"RKE2 supervisor port is vulnerable to unauthenticated remote denial-of-service (DoS) attack via TLS SAN stuffing attack","id":"CVE-2023-32186"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["0.1.9+git.0.66be0d8-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"opensuse-welcome","purl":"pkg:rpm/suse/opensuse-welcome\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2023:0230-1"},{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["0.1.9+git.35.4b9444a-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"opensuse-welcome","purl":"pkg:rpm/suse/opensuse-welcome\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2023:0219-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["0.1.9+git.0.66be0d8-bp154.2.6.1"],"introduced":["0"],"last_affected":[],"package":"opensuse-welcome","purl":"pkg:rpm/opensuse/opensuse-welcome\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2023:0230-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["0.1.9+git.35.4b9444a-bp155.2.3.1"],"introduced":["0"],"last_affected":[],"package":"opensuse-welcome","purl":"pkg:rpm/opensuse/opensuse-welcome\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2023:0219-1"}],"prev":{"headline":"Privilege escalation in Tumbleweed","id":"CVE-2023-32183"},"products":["opensuse-welcome"],"published":"2023-09-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-25","vendors":["openSUSE"]},"summary":"Local attackers can execute code as the user running opensuse-welcome if a custom layout is chosen due to insecure storage of sensitive information.","url":"https://insights.sbomify.com/CVE-2023-32184/"}