CVE-2023-32187 K3s apiserver port is vulnerable to unauthenticated remote denial-of-service (DoS) attack via TLS SAN stuffing attack
Attackers with network access to the K3s API server port can cause a denial of service by exhausting resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-32187?
CVE-2023-32187 is a high-severity denial of service vulnerability in SUSE k3s, published on 18 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An Allocation of Resources Without Limits or Throttling vulnerability in SUSE k3s allows attackers with access to K3s servers' apiserver/supervisor port (TCP 6443) cause denial of service. This issue affects k3s: from v1.24.0 before v1.24.17+k3s1, from v1.25.0 before v1.25.13+k3s1, from v1.26.0 before v1.26.8+k3s1, from sev1.27.0 before v1.27.5+k3s1, from v1.28.0 before v1.28.1+k3s1.
Weakness: CWE-770
Which versions are affected by CVE-2023-32187?
10 open source packages ship an affected version, including github.com/k3s-io/k3s. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/k3s-io/k3s Go | All versions | 1.24.17 |
github.com/k3s-io/k3s Go | All versions | 1.24.17 |
github.com/k3s-io/k3s Go | From 1.25.0 | 1.25.13 |
github.com/k3s-io/k3s Go | From 1.25.0 | 1.25.13 |
github.com/k3s-io/k3s Go | From 1.26.0 | 1.26.8 |
github.com/k3s-io/k3s Go | From 1.26.0 | 1.26.8 |
4 more packages
github.com/k3s-io/k3s Go | From 1.27.0 | 1.27.5 |
github.com/k3s-io/k3s Go | From 1.27.0 | 1.27.5 |
github.com/k3s-io/k3s Go | From 1.28.0 | 1.28.1 |
github.com/k3s-io/k3s Go | From 1.28.0 | 1.28.1 |
Products include K3s K3s.
How do I fix CVE-2023-32187?
Upgrade github.com/k3s-io/k3s to a fixed version for your release line: 1.24.17, 1.25.13, 1.26.8 or 1.27.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-32187 being exploited?
There is no known exploitation of CVE-2023-32187 in the wild and no public exploit code.
Sources
Also known as GHSA-m4hf-6vgr-75r2.