{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32200 in the wild and no public exploit code.","fix":"Upgrade org.apache.jena:jena to 4.9.0 or later.","what":"CVE-2023-32200 is a high-severity code injection vulnerability in Apache Jena, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32200 and fix it if it is affected.\n\nWhat it is: CVE-2023-32200 is a high-severity code injection vulnerability in Apache Jena, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-32200 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.jena:jena (Maven): affected from 3.7.0; fixed in 4.9.0\n- org.apache.jena:jena (Maven): affected from 3.7.0; fixed in 4.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32200/ (Markdown: https://insights.sbomify.com/CVE-2023-32200/index.md)","id":"CVE-2023-32200","markdown":"https://insights.sbomify.com/CVE-2023-32200/index.md","name":"CVE-2023-32200","record":{"aliases":["DEBIAN-CVE-2023-32200","GHSA-j927-w6g7-7c7w","UBUNTU-CVE-2023-32200"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java semantic web library","requires_auth":"none","summary":"Remote attackers can execute arbitrary JavaScript via SPARQL queries due to insufficient restrictions in Apache Jena script engine expressions.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"jena","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-917","name":"Improper Neutralization of Special Elements used in an Expression Language Statement"}],"description":"There is insufficient restrictions of called script functions in Apache Jena\n versions 4.8.0 and earlier. It allows a \nremote user to execute javascript via a SPARQL query.\nThis issue affects Apache Jena: from 3.7.0 through 4.8.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Jena: Exposure of execution in script engine expressions.","id":"CVE-2023-32200","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in TELLUS and TELLUS Lite","id":"CVE-2023-32201"},"packages":[{"ecosystem":"Maven","fixed":["4.9.0"],"introduced":["3.7.0"],"last_affected":[],"package":"org.apache.jena:jena","purl":null,"source":"GHSA-j927-w6g7-7c7w"},{"ecosystem":"Maven","fixed":["4.9.0"],"introduced":["3.7.0"],"last_affected":[],"package":"org.apache.jena:jena","purl":"pkg:maven/org.apache.jena/jena","source":"GHSA-j927-w6g7-7c7w"}],"prev":{"headline":"Rancher user retains access to clusters despite Global Role removal","id":"CVE-2023-32199"},"products":["Apache Jena"],"published":"2023-07-12","related":[{"cvss_score":9.8,"headline":"Processing external DTDs","id":"CVE-2022-28890","kev_date_added":null,"published":"2022-05-05"},{"cvss_score":8.8,"headline":"Apache Jena: Configuration files uploaded by administrative users are not check properly","id":"CVE-2025-50151","kev_date_added":null,"published":"2025-07-21"},{"cvss_score":7.5,"headline":"Apache Jena: Administrative users can create files outside the server directory space via the admin UI","id":"CVE-2025-49656","kev_date_added":null,"published":"2025-07-21"},{"cvss_score":7.5,"headline":"XML External Entity (XXE) vulnerability","id":"CVE-2021-39239","kev_date_added":null,"published":"2021-09-16"},{"cvss_score":5.4,"headline":"Apache Jena: Exposure of arbitrary execution in script engine expressions.","id":"CVE-2023-22665","kev_date_added":null,"published":"2023-04-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-07","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can execute arbitrary JavaScript via SPARQL queries due to insufficient restrictions in Apache Jena script engine expressions.","url":"https://insights.sbomify.com/CVE-2023-32200/"}