# CVE-2023-32200: Apache Jena: Exposure of execution in script engine expressions.

> Remote attackers can execute arbitrary JavaScript via SPARQL queries due to insufficient restrictions in Apache Jena script engine expressions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 7 Oct 2024
- **Also known as:** DEBIAN-CVE-2023-32200, GHSA-j927-w6g7-7c7w, UBUNTU-CVE-2023-32200

## What is CVE-2023-32200?

CVE-2023-32200 is a high-severity code injection vulnerability in Apache Jena, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

There is insufficient restrictions of called script functions in Apache Jena
 versions 4.8.0 and earlier. It allows a 
remote user to execute javascript via a SPARQL query.
This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2023-32200?

2 open source packages ship an affected version, including org.apache.jena:jena. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jena:jena` | Maven | From 3.7.0 | 4.9.0 |
| `org.apache.jena:jena` | Maven | From 3.7.0 | 4.9.0 |

Products: Apache Jena.

## How do I fix CVE-2023-32200?

Upgrade org.apache.jena:jena to 4.9.0 or later.

## Is CVE-2023-32200 being exploited?

There is no known exploitation of CVE-2023-32200 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jena

- [CVE-2022-28890](https://insights.sbomify.com/CVE-2022-28890/): Processing external DTDs (critical 9.8)
- [CVE-2025-50151](https://insights.sbomify.com/CVE-2025-50151/): Apache Jena: Configuration files uploaded by administrative users are not check properly (high 8.8)
- [CVE-2025-49656](https://insights.sbomify.com/CVE-2025-49656/): Apache Jena: Administrative users can create files outside the server directory space via the admin UI (high 7.5)
- [CVE-2021-39239](https://insights.sbomify.com/CVE-2021-39239/): XML External Entity (XXE) vulnerability (high 7.5)
- [CVE-2023-22665](https://insights.sbomify.com/CVE-2023-22665/): Apache Jena: Exposure of arbitrary execution in script engine expressions. (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32200 and fix it if it is affected.

What it is: CVE-2023-32200 is a high-severity code injection vulnerability in Apache Jena, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32200 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jena:jena (Maven): affected from 3.7.0; fixed in 4.9.0
- org.apache.jena:jena (Maven): affected from 3.7.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32200/ (Markdown: https://insights.sbomify.com/CVE-2023-32200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32200
- OSV: https://osv.dev/vulnerability/CVE-2023-32200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32200/
Summaries are generated and may contain mistakes; the official description above is the record.
