# CVE-2023-3224: Code Injection in nuxt/nuxt

> Attackers can execute arbitrary code in Nuxt.js applications, requiring developers to upgrade to a patched version.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2023
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-gc34-5v43-h7v8

## What is CVE-2023-3224?

CVE-2023-3224 is a high-severity code injection vulnerability in nuxt/nuxt, published on 13 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Code Injection in GitHub repository nuxt/nuxt prior to 3.5.3.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-3224?

2 open source packages ship an affected version, including nuxt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt` | npm | From 3.4.0 | 3.4.3 |
| `nuxt` | npm | From 3.4.0 | 3.4.3 |

Products: Nuxt Nuxt.

## How do I fix CVE-2023-3224?

Upgrade nuxt to 3.4.3 or later.

## Is CVE-2023-3224 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3224 exists.

## Other vulnerabilities in nuxt/nuxt

- [CVE-2026-53721](https://insights.sbomify.com/CVE-2026-53721/): Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher (high 8.8)
- [CVE-2024-23657](https://insights.sbomify.com/CVE-2024-23657/): Path Traversal: '../filedir' in Nuxt Devtools (high 8.8)
- [CVE-2024-34344](https://insights.sbomify.com/CVE-2024-34344/): Remote code execution via the browser when running the test locally in nuxt (high 8.8)
- [CVE-2024-42352](https://insights.sbomify.com/CVE-2024-42352/): Server-Side Request Forgery (SSRF) in nuxt-icon (high 8.6)
- [CVE-2025-27415](https://insights.sbomify.com/CVE-2025-27415/): Nuxt allows DOS via cache poisoning with payload rendering response (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3224 and fix it if it is affected.

What it is: CVE-2023-3224 is a high-severity code injection vulnerability in nuxt/nuxt, published on 13 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3224 exists.

Affected packages and fixed versions:
- nuxt (npm): affected from 3.4.0; fixed in 3.4.3
- nuxt (npm): affected from 3.4.0; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3224/ (Markdown: https://insights.sbomify.com/CVE-2023-3224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3224
- OSV: https://osv.dev/vulnerability/CVE-2023-3224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3224/
Summaries are generated and may contain mistakes; the official description above is the record.
