CVE-2023-32301 Discourse's canonical url not being used for topic embeddings

Low 3.1 Published Updated

Attackers can create multiple duplicate topics in Discourse when topic embedding is enabled, leading to data integrity issues.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-32301?

CVE-2023-32301 is a low-severity vulnerability in Discourse Discourse, published on 13 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, multiple duplicate topics could be created if topic embedding is enabled. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. As a workaround, disable topic embedding if it has been enabled.

Weakness: CWE-116

Which versions are affected by CVE-2023-32301?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.4

Products include Discourse Discourse.

How do I fix CVE-2023-32301?

Upgrade discourse to 3.0.4 or later.

Is CVE-2023-32301 being exploited?

There is no known exploitation of CVE-2023-32301 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-32301, GHSA-p2jx-m2j5-hqh4.

Is CVE-2023-32301 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free