{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32305 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-32305 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-32305 is a high-severity vulnerability in aiven-extras, published on 12 May 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32305 and fix it if it is affected.\n\nWhat it is: CVE-2023-32305 is a high-severity vulnerability in aiven-extras, published on 12 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32305 in the wild and no public exploit code.\n\nAffected product: aiven-extras. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32305/ (Markdown: https://insights.sbomify.com/CVE-2023-32305/index.md)","id":"CVE-2023-32305","markdown":"https://insights.sbomify.com/CVE-2023-32305/index.md","name":"CVE-2023-32305","record":{"aliases":["GHSA-7r4w-fw4h-67gp"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PostgreSQL extension","requires_auth":"low_privilege","summary":"A low-privileged user can escalate to superuser privileges in PostgreSQL via the aiven-extras extension, potentially leading to arbitrary code execution on the host.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"aiven","vendor":"aiven"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path","id":"CVE-2023-32305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"Time Tracker has Blind SQL Injection Vulnerability in Reports","id":"CVE-2023-32306"},"packages":[],"prev":{"headline":"Planet's secret file is created with excessive permissions","id":"CVE-2023-32303"},"products":["aiven-extras"],"published":"2023-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["aiven"]},"summary":"A low-privileged user can escalate to superuser privileges in PostgreSQL via the aiven-extras extension, potentially leading to arbitrary code execution on the host.","url":"https://insights.sbomify.com/CVE-2023-32305/"}