# CVE-2023-32305: aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path

> A low-privileged user can escalate to superuser privileges in PostgreSQL via the aiven-extras extension, potentially leading to arbitrary code execution on the host.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-7r4w-fw4h-67gp

## What is CVE-2023-32305?

CVE-2023-32305 is a high-severity vulnerability in aiven-extras, published on 12 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.

Weakness: CWE-20 (Improper Input Validation), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-32305?

It affects 1 product.


Products: Aiven Aiven.

## How do I fix CVE-2023-32305?

No fix has been published for CVE-2023-32305 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-32305 being exploited?

There is no known exploitation of CVE-2023-32305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32305 and fix it if it is affected.

What it is: CVE-2023-32305 is a high-severity vulnerability in aiven-extras, published on 12 May 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32305 in the wild and no public exploit code.

Affected product: aiven-extras. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32305/ (Markdown: https://insights.sbomify.com/CVE-2023-32305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32305
- OSV: https://osv.dev/vulnerability/CVE-2023-32305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32305/
Summaries are generated and may contain mistakes; the official description above is the record.
