{"answers":{"affected":"2 open source packages ship an affected version, including io.dataease:dataease-plugin-common. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32310 exists.","fix":"Upgrade io.dataease:dataease-plugin-common to 1.18.7 or later.","what":"CVE-2023-32310 is a high-severity missing authorization vulnerability in Dataease Dataease, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32310 and fix it if it is affected.\n\nWhat it is: CVE-2023-32310 is a high-severity missing authorization vulnerability in Dataease Dataease, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32310 exists.\n\nAffected packages and fixed versions:\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.18.7\n- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.18.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32310/ (Markdown: https://insights.sbomify.com/CVE-2023-32310/index.md)","id":"CVE-2023-32310","markdown":"https://insights.sbomify.com/CVE-2023-32310/index.md","name":"CVE-2023-32310","record":{"aliases":["GHSA-7hv6-gv38-78wj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"DataEase visualization tool","requires_auth":"low_privilege","summary":"Attackers can delete other users' dashboards or messages via IDOR in DataEase API, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dataease","vendor":"dataease"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"DataEase API interface has IDOR vulnerability","id":"CVE-2023-32310","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"dataease:dataease","products":["dataease:dataease"],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"The CloudExplorer Lite missing permissions check","id":"CVE-2023-32311"},"packages":[{"ecosystem":"Maven","fixed":["1.18.7"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":null,"source":"GHSA-7hv6-gv38-78wj"},{"ecosystem":"Maven","fixed":["1.18.7"],"introduced":["0"],"last_affected":[],"package":"io.dataease:dataease-plugin-common","purl":"pkg:maven/io.dataease/dataease-plugin-common","source":"GHSA-7hv6-gv38-78wj"}],"prev":{"headline":"Arbitrary file inclusion with the pymdowm-snippets extension","id":"CVE-2023-32309"},"products":["dataease"],"published":"2023-06-01","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2024-57707","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":9.8,"headline":"DataEase's H2 datasource has a remote command execution risk","id":"CVE-2024-46997","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.8,"headline":"DataEase data source has deserialization vulnerability","id":"CVE-2023-33963","kev_date_added":null,"published":"2023-06-01"},{"cvss_score":9.8,"headline":"SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed","id":"CVE-2023-28437","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":9.8,"headline":"Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability","id":"CVE-2022-39312","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":9.8,"headline":"Dataease before 1.11.2 allows arbitrary code execution via crafter plugin","id":"CVE-2022-34113","kev_date_added":null,"published":"2022-07-22"},{"cvss_score":9.8,"headline":"Dataease v1.11.1 SQL Injection via parameter dataSourceId","id":"CVE-2022-34115","kev_date_added":null,"published":"2022-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-08","vendors":["dataease"]},"summary":"Attackers can delete other users' dashboards or messages via IDOR in DataEase API, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-32310/"}