# CVE-2023-32310: DataEase API interface has IDOR vulnerability

> Attackers can delete other users' dashboards or messages via IDOR in DataEase API, requiring an upgrade to fix.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-7hv6-gv38-78wj

## What is CVE-2023-32310?

CVE-2023-32310 is a high-severity missing authorization vulnerability in Dataease Dataease, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2023-32310?

2 open source packages ship an affected version, including io.dataease:dataease-plugin-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.dataease:dataease-plugin-common` | Maven | All versions | 1.18.7 |
| `io.dataease:dataease-plugin-common` | Maven | All versions | 1.18.7 |

Products: Dataease Dataease.

## How do I fix CVE-2023-32310?

Upgrade io.dataease:dataease-plugin-common to 1.18.7 or later.

## Is CVE-2023-32310 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32310 exists.

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32310 and fix it if it is affected.

What it is: CVE-2023-32310 is a high-severity missing authorization vulnerability in Dataease Dataease, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32310 exists.

Affected packages and fixed versions:
- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.18.7
- io.dataease:dataease-plugin-common (Maven): affected all versions; fixed in 1.18.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32310/ (Markdown: https://insights.sbomify.com/CVE-2023-32310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32310
- OSV: https://osv.dev/vulnerability/CVE-2023-32310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32310/
Summaries are generated and may contain mistakes; the official description above is the record.
