{"answers":{"affected":"2 open source packages ship an affected version, including vm2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32313 exists.","fix":"Upgrade vm2 to 3.9.18 or later.","what":"CVE-2023-32313 is a medium-severity code injection vulnerability in patriksimek vm2, published on 15 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32313 and fix it if it is affected.\n\nWhat it is: CVE-2023-32313 is a medium-severity code injection vulnerability in patriksimek vm2, published on 15 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32313 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.9.18\n- vm2 (npm): affected all versions; fixed in 3.9.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32313/ (Markdown: https://insights.sbomify.com/CVE-2023-32313/index.md)","id":"CVE-2023-32313","markdown":"https://insights.sbomify.com/CVE-2023-32313/index.md","name":"CVE-2023-32313","record":{"aliases":["GHSA-p5gc-c584-jj6v","ROOT-APP-NPM-CVE-2023-32313"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can manipulate the inspect method in vm2 to modify console.log options, potentially leading to code execution within the sandbox.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vm2","vendor":"vm2_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"vm2 is a sandbox that can run untrusted code with Node's built-in modules. In versions 3.9.17 and lower of vm2 it was possible to get a read-write reference to the node `inspect` method and edit options for `console.log`. As a result a threat actor can edit options for the `console.log` command. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. Users unable to upgrade may make the `inspect` method readonly with `vm.readonly(inspect)` after creating a vm.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Inspect method manipulation in vm2","id":"CVE-2023-32313","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Sandbox Escape","id":"CVE-2023-32314"},"packages":[{"ecosystem":"npm","fixed":["3.9.18"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-p5gc-c584-jj6v"},{"ecosystem":"npm","fixed":["3.9.18"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-p5gc-c584-jj6v"}],"prev":{"headline":"Client secret not mandatory in UmbracoIdentityExtensions","id":"CVE-2023-32312"},"products":["vm2"],"published":"2023-05-15","related":[{"cvss_score":10,"headline":"vm2: Sandbox Escape","id":"CVE-2026-43997","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":10,"headline":"vm2: Sandbox escape","id":"CVE-2026-44005","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":10,"headline":"vm2: Sandbox Escape","id":"CVE-2026-44006","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":10,"headline":"vm2 Sandbox Escape vulnerability","id":"CVE-2023-29017","kev_date_added":null,"published":"2023-04-06"},{"cvss_score":10,"headline":"vm2 vulnerable to Sandbox Escape before v3.9.11","id":"CVE-2022-36067","kev_date_added":null,"published":"2022-09-06"},{"cvss_score":9.9,"headline":"vm2: NodeVM builtin allowlist bypass via `module` builtin's `Module._load` allows sandbox escape","id":"CVE-2026-43999","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":9.8,"headline":"vm2: Snabox breakout via `neutralizeArraySpeciesBatch`","id":"CVE-2026-44008","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-22","vendors":["patriksimek"]},"summary":"Attackers can manipulate the inspect method in vm2 to modify console.log options, potentially leading to code execution within the sandbox.","url":"https://insights.sbomify.com/CVE-2023-32313/"}