# CVE-2023-32323: Synapse Outgoing federation to specific hosts can be disabled by sending malicious invites

> A malicious user can disable outbound federation to specific hosts by sending oversized invite events, causing a denial of service.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-f3wc-3vxv-xmvr, PYSEC-2023-67, UBUNTU-CVE-2023-32323

## What is CVE-2023-32323?

CVE-2023-32323 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 26 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. A malicious user on a Synapse homeserver X with permission to create certain state events can disable outbound federation from X to an arbitrary homeserver Y. Synapse instances with federation disabled are not affected. In versions of Synapse up to and including 1.73, Synapse did not limit the size of `invite_room_state`, meaning that it was possible to create an arbitrarily large invite event. Synapse 1.74 refuses to create oversized `invite_room_state` fields. Server operators should upgrade to Synapse 1.74 or newer urgently.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-32323?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.74.0 |
| `matrix-synapse` | PyPI | All versions | 1.74.0 |
| `matrix-synapse` | PyPI | All versions | 1.74.0 |

Products: Matrix Synapse.

## How do I fix CVE-2023-32323?

Upgrade matrix-synapse to 1.74.0 or later.

## Is CVE-2023-32323 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32323 exists.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32323 and fix it if it is affected.

What it is: CVE-2023-32323 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 26 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32323 exists.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.74.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.74.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.74.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32323/ (Markdown: https://insights.sbomify.com/CVE-2023-32323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32323
- OSV: https://osv.dev/vulnerability/CVE-2023-32323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32323/
Summaries are generated and may contain mistakes; the official description above is the record.
