{"answers":{"affected":"2 open source packages ship an affected version, including posthog-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32325 in the wild and no public exploit code.","fix":"Upgrade posthog-js to 1.57.2 or later.","what":"CVE-2023-32325 is a medium-severity cross-site scripting vulnerability in posthog-js, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-32325 and fix it if it is affected.\n\nWhat it is: CVE-2023-32325 is a medium-severity cross-site scripting vulnerability in posthog-js, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-32325 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- posthog-js (npm): affected all versions; fixed in 1.57.2\n- posthog-js (npm): affected all versions; fixed in 1.57.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32325/ (Markdown: https://insights.sbomify.com/CVE-2023-32325/index.md)","id":"CVE-2023-32325","markdown":"https://insights.sbomify.com/CVE-2023-32325/index.md","name":"CVE-2023-32325","record":{"aliases":["GHSA-8775-5hwv-wr6v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostHog JavaScript library","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in PostHog-js allows attackers to inject malicious scripts, requiring users to upgrade the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"posthog-js","vendor":"posthog"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in PostHog-js","id":"CVE-2023-32325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"IBM Security Access Manager Container XML external entity injection","id":"CVE-2023-32327"},"packages":[{"ecosystem":"npm","fixed":["1.57.2"],"introduced":["0"],"last_affected":[],"package":"posthog-js","purl":null,"source":"GHSA-8775-5hwv-wr6v"},{"ecosystem":"npm","fixed":["1.57.2"],"introduced":["0"],"last_affected":[],"package":"posthog-js","purl":"pkg:npm/posthog-js","source":"GHSA-8775-5hwv-wr6v"}],"prev":{"headline":"OpenPrinting CUPS vulnerable to heap buffer overflow","id":"CVE-2023-32324"},"products":["posthog-js"],"published":"2023-05-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["PostHog"]},"summary":"Cross-site scripting vulnerability in PostHog-js allows attackers to inject malicious scripts, requiring users to upgrade the library.","url":"https://insights.sbomify.com/CVE-2023-32325/"}