# CVE-2023-32325: Cross-site scripting in PostHog-js

> Cross-site scripting vulnerability in PostHog-js allows attackers to inject malicious scripts, requiring users to upgrade the library.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-8775-5hwv-wr6v

## What is CVE-2023-32325?

CVE-2023-32325 is a medium-severity cross-site scripting vulnerability in posthog-js, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-32325?

2 open source packages ship an affected version, including posthog-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `posthog-js` | npm | All versions | 1.57.2 |
| `posthog-js` | npm | All versions | 1.57.2 |

Products: Posthog Posthog-Js.

## How do I fix CVE-2023-32325?

Upgrade posthog-js to 1.57.2 or later.

## Is CVE-2023-32325 being exploited?

There is no known exploitation of CVE-2023-32325 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32325 and fix it if it is affected.

What it is: CVE-2023-32325 is a medium-severity cross-site scripting vulnerability in posthog-js, published on 26 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32325 in the wild and no public exploit code.

Affected packages and fixed versions:
- posthog-js (npm): affected all versions; fixed in 1.57.2
- posthog-js (npm): affected all versions; fixed in 1.57.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32325/ (Markdown: https://insights.sbomify.com/CVE-2023-32325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32325
- OSV: https://osv.dev/vulnerability/CVE-2023-32325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32325/
Summaries are generated and may contain mistakes; the official description above is the record.
