CVE-2023-3247 Missing error check and insufficient random bytes in HTTP Digest authentication for SOAP

Low 2.6 Published Updated

A flaw in PHP's SOAP HTTP Digest authentication allows memory disclosure and weak nonce generation, enabling potential session hijacking or data leakage.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3247?

CVE-2023-3247 is a low-severity vulnerability in Php Php, published on 22 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before 8.2.7 when using SOAP HTTP Digest Authentication, random value generator was not checked for failure, and was using narrower range of values than it should have. In case of random generator failure, it could lead to a disclosure of 31 bits of uninitialized memory from the client to the server, and it also made easier to a malicious server to guess the client's nonce.

Weakness: CWE-330, CWE-252

Which versions are affected by CVE-2023-3247?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.

PackageAffectedFixed in
libphp BitnamiFrom 8.0.08.0.29, 8.1.20, 8.2.7
php BitnamiFrom 8.0.08.0.29, 8.1.20, 8.2.7
php-min BitnamiFrom 8.0.08.0.29, 8.1.20, 8.2.7
Linux distribution packages (37)
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP4All versions7.4.33-150400.4.25.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP4All versions7.4.33-150400.4.25.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP4All versions7.4.33-150400.4.25.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP4All versions7.4.33-150400.4.25.1
apache2-mod_php7 SUSE:Linux Enterprise Module for Legacy 15 SP5All versions7.4.33-150400.4.25.1
php7 SUSE:Linux Enterprise Module for Legacy 15 SP5All versions7.4.33-150400.4.25.1
php7-fastcgi SUSE:Linux Enterprise Module for Legacy 15 SP5All versions7.4.33-150400.4.25.1
php7-fpm SUSE:Linux Enterprise Module for Legacy 15 SP5All versions7.4.33-150400.4.25.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP4All versions7.4.33-150400.4.25.1
php7-embed SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions7.4.33-150400.4.25.1
php74 SUSE:Linux Enterprise Module for Web and Scripting 12All versions7.4.33-1.59.1
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP4All versions8.0.29-150400.4.34.1
apache2-mod_php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php8-embed SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php8-fastcgi SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php8-fpm SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php8-test SUSE:Linux Enterprise Module for Web and Scripting 15 SP5All versions8.0.29-150400.4.34.1
php74 SUSE:Linux Enterprise Software Development Kit 12 SP5All versions7.4.33-1.59.1
php7 SUSE:Manager Server 4.2All versions7.4.33-150200.3.57.1
apache2-mod_php7 openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
apache2-mod_php8 openSUSE:Leap 15.4All versions8.0.29-150400.4.34.1
php7 openSUSE:Leap 15.4All versions7.4.33-150200.3.57.1
php7 openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
php7-embed openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
php7-fastcgi openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
php7-fpm openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
php7-test openSUSE:Leap 15.4All versions7.4.33-150400.4.25.1
php8 openSUSE:Leap 15.4All versions8.0.29-150400.4.34.1
php8-embed openSUSE:Leap 15.4All versions8.0.29-150400.4.34.1
php8-fastcgi openSUSE:Leap 15.4All versions8.0.29-150400.4.34.1
php8-fpm openSUSE:Leap 15.4All versions8.0.29-150400.4.34.1

Products include Php Php.

How do I fix CVE-2023-3247?

Upgrade libphp to a fixed version for your release line: 8.0.29, 8.1.20 or 8.2.7.

Is CVE-2023-3247 being exploited?

There is no known exploitation of CVE-2023-3247 in the wild and no public exploit code.

All Php Php vulnerabilities

Sources

Also known as AZL-27435, BIT-libphp-2023-3247, BIT-php-2023-3247, BIT-php-min-2023-3247, CLSA-2023-1699907419, CLSA-2023-1699907901 and 14 more.

Is CVE-2023-3247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free