{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32558 in the wild and no public exploit code.","fix":"Upgrade node to 20.5.1 or later.","what":"CVE-2023-32558 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32558 and fix it if it is affected.\n\nWhat it is: CVE-2023-32558 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 12 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32558 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 20.0.0; fixed in 20.5.1\n- node-min (Bitnami): affected from 20.0.0; fixed in 20.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32558/ (Markdown: https://insights.sbomify.com/CVE-2023-32558/index.md)","id":"CVE-2023-32558","markdown":"https://insights.sbomify.com/CVE-2023-32558/index.md","name":"CVE-2023-32558","record":{"aliases":["BIT-node-2023-32558","BIT-node-min-2023-32558","GHSA-h9p4-9jqg-j34h"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can bypass the experimental permission model in Node.js 20.x via path traversal using the deprecated process.binding API.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"The use of the deprecated API `process.binding()` can bypass the permission model through path traversal. \n\nThis vulnerability affects all users using the experimental permission model in Node.js 20.x.\n\nPlease note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in Node","id":"CVE-2023-32558","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Privilege escalation in Node","id":"CVE-2023-32559"},"packages":[{"ecosystem":"Bitnami","fixed":["20.5.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2023-32558"},{"ecosystem":"Bitnami","fixed":["20.5.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2023-32558"}],"prev":{"headline":"Path traversal in Trend Micro Apex One","id":"CVE-2023-32557"},"products":["Node"],"published":"2023-09-12","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-04-30","vendors":["NodeJS"]},"summary":"Attackers can bypass the experimental permission model in Node.js 20.x via path traversal using the deprecated process.binding API.","url":"https://insights.sbomify.com/CVE-2023-32558/"}