{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-32570 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-32570 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32570 and fix it if it is affected.\n\nWhat it is: CVE-2023-32570 is a medium-severity vulnerability in Fedoraproject Fedora, published on 10 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32570 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32570/ (Markdown: https://insights.sbomify.com/CVE-2023-32570/index.md)","id":"CVE-2023-32570","markdown":"https://insights.sbomify.com/CVE-2023-32570/index.md","name":"CVE-2023-32570","record":{"aliases":["BELL-CVE-2023-32570","DEBIAN-CVE-2023-32570","ECHO-ca6c-4314-8dc3","GHSA-6q7w-3rwf-fh47","ROOT-OS-DEBIAN-12-CVE-2023-32570","SUSE-SU-2023:2618-1","UBUNTU-CVE-2023-32570","openSUSE-SU-2024:13730-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AV1 decoder library","requires_auth":"none","summary":"A race condition in the dav1d AV1 decoder library allows attackers to cause an application crash via crafted video files.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"dav1d","vendor":"videolan"}],"cvss":{"score":5.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"VideoLAN dav1d before 1.2.0 has a thread_task.c race condition that can lead to an application crash, related to dav1d_decode_frame_exit.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","SUSE:Linux Enterprise Module for Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Race condition in n/a","id":"CVE-2023-32570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"race_condition","year":"2023"},"n_packages":3,"n_references":5,"next":{"headline":"Dynamic Linq vulnerable to remote code execution","id":"CVE-2023-32571"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15 SP5","fixed":["1.0.0-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"dav1d","purl":"pkg:rpm/suse/dav1d\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015%20SP5","source":"SUSE-SU-2023:2618-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP5","fixed":["1.0.0-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"dav1d","purl":"pkg:rpm/suse/dav1d\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP5","source":"SUSE-SU-2023:2618-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["1.0.0-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"dav1d","purl":"pkg:rpm/opensuse/dav1d\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2023:2618-1"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2023-32569"},"products":["n/a"],"published":"2023-05-10","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-28","vendors":["n/a"]},"summary":"A race condition in the dav1d AV1 decoder library allows attackers to cause an application crash via crafted video files.","url":"https://insights.sbomify.com/CVE-2023-32570/"}