# CVE-2023-32571: Dynamic Linq vulnerable to remote code execution


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Jun 2023
- **Updated:** 6 Dec 2024
- **Also known as:** GHSA-w65q-jcmv-28gj

## What is CVE-2023-32571?

CVE-2023-32571 is a critical vulnerability in n/a, published on 22 Jun 2023. 

### Official description

Dynamic Linq 1.0.7.10 through 1.2.25 before 1.3.0 allows attackers to execute arbitrary code and commands when untrusted input to methods including Where, Select, OrderBy is parsed.

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2023-32571?

2 open source packages ship an affected version, including System.Linq.Dynamic.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `System.Linq.Dynamic.Core` | NuGet | From 1.0.7.10 | 1.3.0 |
| `System.Linq.Dynamic.Core` | NuGet | From 1.0.7.10 | 1.3.0 |

Products: Dynamic-Linq Linq.

## How do I fix CVE-2023-32571?

Upgrade System.Linq.Dynamic.Core to 1.3.0 or later.

## Is CVE-2023-32571 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32571 exists.

Public exploit code:

- https://github.com/Tris0n/CVE-2023-32571-POC (github_poc): https://github.com/Tris0n/CVE-2023-32571-POC
- https://github.com/vert16x/CVE-2023-32571-POC (github_poc): https://github.com/vert16x/CVE-2023-32571-POC
- Proof of Concept for CVE-2023-32571 (github_poc): https://github.com/SecTex/CVE-2023-32571

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32571 and fix it if it is affected.

What it is: CVE-2023-32571 is a critical vulnerability in n/a, published on 22 Jun 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32571 exists.

Affected packages and fixed versions:
- System.Linq.Dynamic.Core (NuGet): affected from 1.0.7.10; fixed in 1.3.0
- System.Linq.Dynamic.Core (NuGet): affected from 1.0.7.10; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32571/ (Markdown: https://insights.sbomify.com/CVE-2023-32571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32571
- OSV: https://osv.dev/vulnerability/CVE-2023-32571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32571/
Summaries are generated and may contain mistakes; the official description above is the record.
