{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32672 in the wild and no public exploit code.","fix":"Upgrade apache-superset to 2.1.1 or later.","what":"CVE-2023-32672 is a medium-severity missing authorization vulnerability in Apache Superset, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32672 and fix it if it is affected.\n\nWhat it is: CVE-2023-32672 is a medium-severity missing authorization vulnerability in Apache Superset, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions up to 2.1.0; no fix listed\n- apache-superset (PyPI): affected all versions up to 2.1.0; no fix listed\n- apache-superset (PyPI): affected all versions; fixed in 2.1.1\n- superset (Bitnami): affected all versions; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32672/ (Markdown: https://insights.sbomify.com/CVE-2023-32672/index.md)","id":"CVE-2023-32672","markdown":"https://insights.sbomify.com/CVE-2023-32672/index.md","name":"CVE-2023-32672","record":{"aliases":["BIT-superset-2023-32672","GHSA-95ch-p3gw-23qg","PYSEC-2026-1166"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Authenticated users can bypass SQL parser checks to query unauthorized tables in Apache Superset, leading to unauthorized data access.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An Incorrect authorisation check in SQLLab in Apache Superset versions up to and including 2.1.0. This vulnerability allows an authenticated user to query tables that they do not have proper access to within Superset. The vulnerability can be exploited by leveraging a SQL parsing vulnerability.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: SQL parser edge case bypasses data access authorization","id":"CVE-2023-32672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"missing_authorization","year":"2023"},"n_packages":4,"n_references":1,"next":{"headline":"Privilege escalation in HP PC Hardware Diagnostics Windows, HP Image Assistant, and HP Thunderbolt Dock G2 Firmware","id":"CVE-2023-32673"},"packages":[{"ecosystem":"Bitnami","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2023-32672"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.1.0"],"package":"apache-superset","purl":null,"source":"GHSA-95ch-p3gw-23qg"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.1.0"],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-95ch-p3gw-23qg"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1166"}],"prev":{"headline":"BuddyBoss XSS vulnerability","id":"CVE-2023-32671"},"products":["Apache Superset"],"published":"2023-09-06","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-26","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can bypass SQL parser checks to query unauthorized tables in Apache Superset, leading to unauthorized data access.","url":"https://insights.sbomify.com/CVE-2023-32672/"}