# CVE-2023-32675: Nonpayable default functions are sometimes payable in vyper

> Attackers can send funds to nonpayable default functions in Vyper contracts, violating expected payment restrictions and potentially altering contract state.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2023
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-vxmm-cwh2-q762, PYSEC-2023-80

## What is CVE-2023-32675?

CVE-2023-32675 is a low-severity vulnerability in vyperlang vyper, published on 19 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In contracts with more than one regular nonpayable function, it is possible to send funds to the default function, even if the default function is marked `nonpayable`. This applies to contracts compiled with vyper versions prior to 0.3.8. This issue was fixed by the removal of the global `calldatasize` check in commit `02339dfda`. Users are advised to upgrade to version 0.3.8. Users unable to upgrade should avoid use of nonpayable default functions.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-32675?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |
| `vyper` | PyPI | All versions | 0.3.8 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-32675?

Upgrade vyper to 0.3.8 or later.

## Is CVE-2023-32675 being exploited?

There is no known exploitation of CVE-2023-32675 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32675 and fix it if it is affected.

What it is: CVE-2023-32675 is a low-severity vulnerability in vyperlang vyper, published on 19 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32675 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8
- vyper (PyPI): affected all versions; fixed in 0.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32675/ (Markdown: https://insights.sbomify.com/CVE-2023-32675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32675
- OSV: https://osv.dev/vulnerability/CVE-2023-32675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32675/
Summaries are generated and may contain mistakes; the official description above is the record.
