# CVE-2023-32679: Remote Code Execution via unrestricted file extension in Craft CMS

> An attacker with admin privileges in a development or improperly configured environment can achieve remote code execution via unrestricted file extensions.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2023
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-vqxf-r9ph-cc9c

## What is CVE-2023-32679?

CVE-2023-32679 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 19 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft CMS is an open source content management system. In affected versions of Craft CMS an unrestricted file extension may lead to Remote Code Execution. If the name parameter value is not empty string('') in the View.php's doesTemplateExist() -> resolveTemplate() -> _resolveTemplateInternal() -> _resolveTemplate() function, it returns directly without extension verification, so that arbitrary extension files are rendered as twig templates. When attacker with admin privileges on a DEV or an improperly configured STG or PROD environment, they can exploit this vulnerability to remote code execution. Code execution may grant the attacker access to the host operating system. This issue has been addressed in version 4.4.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-32679?

2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.4.6 |
| `craftcms/cms` | Packagist | From 4.0.0 | 4.4.6 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2023-32679?

Upgrade craftcms/cms to 4.4.6 or later.

## Is CVE-2023-32679 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32679 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32679 and fix it if it is affected.

What it is: CVE-2023-32679 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 19 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-32679 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.4.6
- craftcms/cms (Packagist): affected from 4.0.0; fixed in 4.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32679/ (Markdown: https://insights.sbomify.com/CVE-2023-32679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32679
- OSV: https://osv.dev/vulnerability/CVE-2023-32679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32679/
Summaries are generated and may contain mistakes; the official description above is the record.
