# CVE-2023-32682: Improper checks for deactivated users during login in synapse

> Deactivated users may bypass authentication and log in under specific uncommon configurations, allowing unauthorized access to their accounts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-26c5-ppr8-f33p, PYSEC-2023-84, UBUNTU-CVE-2023-32682

## What is CVE-2023-32682?

CVE-2023-32682 is a medium-severity authentication bypass vulnerability in matrix-org synapse, published on 6 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is a Matrix protocol homeserver written in Python with the Twisted framework. In affected versions it may be possible for a deactivated user to login when using uncommon configurations. This only applies if any of the following are true: 1. JSON Web Tokens are enabled for login via the `jwt_config.enabled` configuration setting. 2. The local password database is enabled via the `password_config.enabled` and `password_config.localdb_enabled` configuration settings *and* a user's password is updated via an admin API after a user is deactivated. Note that the local password database is enabled by default, but it is uncommon to set a user's password after they've been deactivated. Installations that are configured to only allow login via Single Sign-On (SSO) via CAS, SAML or OpenID Connect (OIDC); or via an external password provider (e.g. LDAP) are not affected. If not using JSON Web Tokens, ensure that deactivated users do not have a password set. This issue has been addressed in version 1.85.0. Users are advised to upgrade.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-32682?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |

Products: Matrix Synapse.

## How do I fix CVE-2023-32682?

Upgrade matrix-synapse to 1.85.0 or later.

## Is CVE-2023-32682 being exploited?

There is no known exploitation of CVE-2023-32682 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32682 and fix it if it is affected.

What it is: CVE-2023-32682 is a medium-severity authentication bypass vulnerability in matrix-org synapse, published on 6 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32682 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32682/ (Markdown: https://insights.sbomify.com/CVE-2023-32682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32682
- OSV: https://osv.dev/vulnerability/CVE-2023-32682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32682/
Summaries are generated and may contain mistakes; the official description above is the record.
