# CVE-2023-32683: URL deny list bypass via oEmbed and image URLs when generating previews in Synapse

> Attackers can bypass URL blacklists via oEmbed or image previews in Synapse, enabling server-side request forgery against allowed IP ranges.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-98px-6486-j7qc, PYSEC-2023-85, UBUNTU-CVE-2023-32683

## What is CVE-2023-32683?

CVE-2023-32683 is a low-severity server-side request forgery vulnerability in matrix-org synapse, published on 6 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Synapse is a Matrix protocol homeserver written in Python with the Twisted framework. A discovered oEmbed or image URL can bypass the `url_preview_url_blacklist` setting potentially allowing server side request forgery or bypassing network policies. Impact is limited to IP addresses allowed by the `url_preview_ip_range_blacklist` setting (by default this only allows public IPs) and by the limited information returned to the client: 1. For discovered oEmbed URLs, any non-JSON response or a JSON response which includes non-oEmbed information is discarded. 2. For discovered image URLs, any non-image response is discarded. Systems which have URL preview disabled (via the `url_preview_enabled` setting) or have not configured a `url_preview_url_blacklist` are not affected. This issue has been addressed in version 1.85.0. Users are advised to upgrade. User unable to upgrade may also disable URL previews.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-32683?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |
| `matrix-synapse` | PyPI | All versions | 1.85.0 |

Products: Matrix Synapse.

## How do I fix CVE-2023-32683?

Upgrade matrix-synapse to 1.85.0 or later.

## Is CVE-2023-32683 being exploited?

There is no known exploitation of CVE-2023-32683 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32683 and fix it if it is affected.

What it is: CVE-2023-32683 is a low-severity server-side request forgery vulnerability in matrix-org synapse, published on 6 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32683 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.85.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32683/ (Markdown: https://insights.sbomify.com/CVE-2023-32683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32683
- OSV: https://osv.dev/vulnerability/CVE-2023-32683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32683/
Summaries are generated and may contain mistakes; the official description above is the record.
