# CVE-2023-32685: Clipboard based cross-site scripting (blocked with default CSP) in Kanboard

> Attackers can inject malicious HTML via clipboard content in Kanboard, leading to XSS if CSP is misconfigured, requiring a patch to mitigate.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-hjmw-gm82-r4gv

## What is CVE-2023-32685?

CVE-2023-32685 is a medium-severity cross-site scripting vulnerability in kanboard, published on 30 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kanboard is project management software that focuses on the Kanban methodology. Due to improper handling of elements under the `contentEditable` element, maliciously crafted clipboard content can inject arbitrary HTML tags into the DOM. A low-privileged attacker with permission to attach a document on a vulnerable Kanboard instance can trick the victim into pasting malicious screenshot data and achieve cross-site scripting if CSP is improperly configured. This issue has been patched in version 1.2.29.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-32685?

It affects 1 product.


Products: Kanboard Kanboard.

## How do I fix CVE-2023-32685?

No fix has been published for CVE-2023-32685 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-32685 being exploited?

There is no known exploitation of CVE-2023-32685 in the wild and no public exploit code.

## Other vulnerabilities in kanboard

- [CVE-2026-21881](https://insights.sbomify.com/CVE-2026-21881/): Kanboard is Vulnerable to Reverse Proxy Authentication Bypass (critical 9.1)
- [CVE-2025-55010](https://insights.sbomify.com/CVE-2025-55010/): Kanboard Authenticated Admin Remote Code Execution via Unsafe Deserialization of Events (critical 9.1)
- [CVE-2024-51747](https://insights.sbomify.com/CVE-2024-51747/): Arbitrary File Read and Delete in kanboard (critical 9.1)
- [CVE-2024-51748](https://insights.sbomify.com/CVE-2024-51748/): Remote code execution through language setting in kanboard (critical 9.1)
- [CVE-2017-12850](https://insights.sbomify.com/CVE-2017-12850/): Business logic in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32685 and fix it if it is affected.

What it is: CVE-2023-32685 is a medium-severity cross-site scripting vulnerability in kanboard, published on 30 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32685 in the wild and no public exploit code.

Affected product: kanboard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32685/ (Markdown: https://insights.sbomify.com/CVE-2023-32685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32685
- OSV: https://osv.dev/vulnerability/CVE-2023-32685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32685/
Summaries are generated and may contain mistakes; the official description above is the record.
