# CVE-2023-32686: kiwitcms vulnerable to stored XSS via unrestricted files upload

> Attackers can upload malicious files to bypass CSP and execute arbitrary JavaScript in users' browsers via stored XSS in Kiwi TCMS.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-x7c2-7wvg-jpx7, PYSEC-2026-1500

## What is CVE-2023-32686?

CVE-2023-32686 is a high-severity cross-site scripting vulnerability in kiwitcms Kiwi, published on 27 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kiwi TCMS is an open source test management system for both manual and automated testing. Kiwi TCMS allows users to upload attachments to test plans, test cases, etc. Earlier versions of Kiwi TCMS had introduced upload validators in order to prevent potentially dangerous files from being uploaded. The upload validation checks were not robust enough which left the possibility of an attacker to circumvent them and upload a potentially dangerous file. Exploiting this flaw, a combination of files could be uploaded so that they work together to circumvent the existing Content-Security-Policy and allow execution of arbitrary JavaScript in the browser. This issue has been patched in version 12.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-32686?

3 open source packages ship an affected version, including kiwitcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kiwitcms` | PyPI | All versions | 12.3 |
| `kiwitcms` | PyPI | All versions | 12.3 |
| `kiwitcms` | PyPI | All versions | 12.3 |

Products: Kiwitcms Kiwi Tcms.

## How do I fix CVE-2023-32686?

Upgrade kiwitcms to 12.3 or later.

## Is CVE-2023-32686 being exploited?

There is no known exploitation of CVE-2023-32686 in the wild and no public exploit code.

## Other vulnerabilities in kiwitcms Kiwi

- [CVE-2023-30628](https://insights.sbomify.com/CVE-2023-30628/): Kiwi TCMS has command injection vulnerability in changelog.yml CI workflow (high 8.8)
- [CVE-2023-36809](https://insights.sbomify.com/CVE-2023-36809/): Kiwi TCMS's misconfigured HTTP headers allow stored XSS execution with Firefox (high 8.1)
- [CVE-2023-33977](https://insights.sbomify.com/CVE-2023-33977/): Stored cross site scripting (XSS) via unrestricted file upload in Kiwi TCMS (high 8.1)
- [CVE-2023-30613](https://insights.sbomify.com/CVE-2023-30613/): Kiwi TCMS unrestricted file upload vulnerability (high 8.1)
- [CVE-2023-27489](https://insights.sbomify.com/CVE-2023-27489/): Stored cross site scripting via SVG file upload in Kiwi TCMS (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32686 and fix it if it is affected.

What it is: CVE-2023-32686 is a high-severity cross-site scripting vulnerability in kiwitcms Kiwi, published on 27 May 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-32686 in the wild and no public exploit code.

Affected packages and fixed versions:
- kiwitcms (PyPI): affected all versions; fixed in 12.3
- kiwitcms (PyPI): affected all versions; fixed in 12.3
- kiwitcms (PyPI): affected all versions; fixed in 12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32686/ (Markdown: https://insights.sbomify.com/CVE-2023-32686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32686
- OSV: https://osv.dev/vulnerability/CVE-2023-32686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32686/
Summaries are generated and may contain mistakes; the official description above is the record.
