{"answers":{"affected":"2 open source packages ship an affected version, including parse-server-push-adapter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32688 in the wild and no public exploit code.","fix":"Upgrade parse-server-push-adapter to 4.1.3 or later.","what":"CVE-2023-32688 is a medium-severity denial of service vulnerability in parse-community parse-server-push-adapter, published on 27 May 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32688 and fix it if it is affected.\n\nWhat it is: CVE-2023-32688 is a medium-severity denial of service vulnerability in parse-community parse-server-push-adapter, published on 27 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32688 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server-push-adapter (npm): affected all versions; fixed in 4.1.3\n- parse-server-push-adapter (npm): affected all versions; fixed in 4.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32688/ (Markdown: https://insights.sbomify.com/CVE-2023-32688/index.md)","id":"CVE-2023-32688","markdown":"https://insights.sbomify.com/CVE-2023-32688/index.md","name":"CVE-2023-32688","record":{"aliases":["GHSA-mxhg-rvwx-x993"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server push adapter","requires_auth":"high_privilege","summary":"An attacker can crash the Parse Server by sending an invalid push notification payload, requiring an upgrade to the push adapter library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parse_server_push_adapter","vendor":"parseplatform"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Invalid push request payload crashes Parse Server","id":"CVE-2023-32688","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Parse Server vulnerable to phishing attack vulnerability that involves uploading malicious HTML file","id":"CVE-2023-32689"},"packages":[{"ecosystem":"npm","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"parse-server-push-adapter","purl":null,"source":"GHSA-mxhg-rvwx-x993"},{"ecosystem":"npm","fixed":["4.1.3"],"introduced":["0"],"last_affected":[],"package":"parse-server-push-adapter","purl":"pkg:npm/parse-server-push-adapter","source":"GHSA-mxhg-rvwx-x993"}],"prev":{"headline":"Insufficiently Protected ChatBot Credentials in tgstation-server","id":"CVE-2023-32687"},"products":["parse-server-push-adapter"],"published":"2023-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-14","vendors":["parse-community"]},"summary":"An attacker can crash the Parse Server by sending an invalid push notification payload, requiring an upgrade to the push adapter library.","url":"https://insights.sbomify.com/CVE-2023-32688/"}