# CVE-2023-32688: Invalid push request payload crashes Parse Server

> An attacker can crash the Parse Server by sending an invalid push notification payload, requiring an upgrade to the push adapter library.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2023
- **Updated:** 14 Jan 2025
- **Also known as:** GHSA-mxhg-rvwx-x993

## What is CVE-2023-32688?

CVE-2023-32688 is a medium-severity denial of service vulnerability in parse-community parse-server-push-adapter, published on 27 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-32688?

2 open source packages ship an affected version, including parse-server-push-adapter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server-push-adapter` | npm | All versions | 4.1.3 |
| `parse-server-push-adapter` | npm | All versions | 4.1.3 |

Products: Parseplatform Parse Server Push Adapter.

## How do I fix CVE-2023-32688?

Upgrade parse-server-push-adapter to 4.1.3 or later.

## Is CVE-2023-32688 being exploited?

There is no known exploitation of CVE-2023-32688 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32688 and fix it if it is affected.

What it is: CVE-2023-32688 is a medium-severity denial of service vulnerability in parse-community parse-server-push-adapter, published on 27 May 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32688 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server-push-adapter (npm): affected all versions; fixed in 4.1.3
- parse-server-push-adapter (npm): affected all versions; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32688/ (Markdown: https://insights.sbomify.com/CVE-2023-32688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32688
- OSV: https://osv.dev/vulnerability/CVE-2023-32688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32688/
Summaries are generated and may contain mistakes; the official description above is the record.
