# CVE-2023-32689: Parse Server vulnerable to phishing attack vulnerability that involves uploading malicious HTML file

> Attackers can upload malicious HTML files to Parse Server to conduct phishing attacks and steal user session tokens from local storage.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** BIT-parse-2023-32689, GHSA-9prm-jqwx-45x9

## What is CVE-2023-32689?

CVE-2023-32689 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 30 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 5.4.4 and 6.1.1 are vulnerable to a phishing attack vulnerability that involves a user uploading malicious files. A malicious user could upload an HTML file to Parse Server via its public API. That HTML file would then be accessible at the internet domain at which Parse Server is hosted. The URL of the the uploaded HTML could be shared for phishing attacks. The HTML page may seem legitimate because it is served under the internet domain where Parse Server is hosted, which may be the same as a company's official website domain.

An additional security issue arises when the Parse JavaScript SDK is used. The SDK stores sessions in the internet browser's local storage, which usually restricts data access depending on the internet domain. A malicious HTML file could contain a script that retrieves the user's session token from local storage and then share it with the attacker.

The fix included in versions 5.4.4 and 6.1.1 adds a new Parse Server option `fileUpload.fileExtensions` to restrict file upload on Parse Server by file extension. It is recommended to restrict file upload for HTML file extensions, which this fix disables by default. If an app requires upload of files with HTML file extensions, the option can be set to `['.*']` or another custom value to override the default.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-32689?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 5.4.4 |
| `parse-server` | npm | All versions | 5.4.4 |
| `parse-server` | npm | From 6.0.0 | 6.1.1 |
| `parse-server` | npm | From 6.0.0 | 6.1.1 |
| `parse` | Bitnami | All versions | 5.4.4, 6.1.1 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2023-32689?

Upgrade parse-server to a fixed version for your release line: 5.4.4 or 6.1.1.

## Is CVE-2023-32689 being exploited?

There is no known exploitation of CVE-2023-32689 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32689 and fix it if it is affected.

What it is: CVE-2023-32689 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 30 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32689 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 5.4.4
- parse-server (npm): affected all versions; fixed in 5.4.4
- parse-server (npm): affected from 6.0.0; fixed in 6.1.1
- parse-server (npm): affected from 6.0.0; fixed in 6.1.1
- parse (Bitnami): affected all versions; fixed in 5.4.4, 6.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32689/ (Markdown: https://insights.sbomify.com/CVE-2023-32689/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32689
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32689
- OSV: https://osv.dev/vulnerability/CVE-2023-32689

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32689/
Summaries are generated and may contain mistakes; the official description above is the record.
