{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-32692 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.3.5 or later.","what":"CVE-2023-32692 is a critical code injection vulnerability in CodeIgniter4, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-32692 and fix it if it is affected.\n\nWhat it is: CVE-2023-32692 is a critical code injection vulnerability in CodeIgniter4, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-32692 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.3.5\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.3.5\n- codeigniter (Bitnami): affected all versions; fixed in 4.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-32692/ (Markdown: https://insights.sbomify.com/CVE-2023-32692/index.md)","id":"CVE-2023-32692","markdown":"https://insights.sbomify.com/CVE-2023-32692/index.md","name":"CVE-2023-32692","record":{"aliases":["BIT-codeigniter-2023-32692","GHSA-m6m8-6gq8-c9fj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary code via Validation Placeholders in the CodeIgniter PHP framework, requiring an upgrade to the patched version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-05-19","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-19T08:08:43Z","kind":"github_poc","ref":"https://github.com/mogwailabs/CVE-2023-32692-CodeIgniter4","stars":2,"title":"Example application, vulnerable to CVE-2023-32692 (Validation Rule Injection in the PHP Framework CodeIgniter)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693"},"packages":[{"ecosystem":"Bitnami","fixed":["4.3.5"],"introduced":["0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2023-32692"},{"ecosystem":"Packagist","fixed":["4.3.5"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-m6m8-6gq8-c9fj"},{"ecosystem":"Packagist","fixed":["4.3.5"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-m6m8-6gq8-c9fj"}],"prev":{"headline":"ginuerzh/gost vulnerable to Timing Attack","id":"CVE-2023-32691"},"products":["CodeIgniter4"],"published":"2023-05-30","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-10","vendors":["codeigniter4"]},"summary":"Attackers can execute arbitrary code via Validation Placeholders in the CodeIgniter PHP framework, requiring an upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2023-32692/"}