# CVE-2023-32692: Remote Code Execution Vulnerability in Validation Placeholders

> Attackers can execute arbitrary code via Validation Placeholders in the CodeIgniter PHP framework, requiring an upgrade to the patched version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** BIT-codeigniter-2023-32692, GHSA-m6m8-6gq8-c9fj

## What is CVE-2023-32692?

CVE-2023-32692 is a critical code injection vulnerability in CodeIgniter4, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-32692?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.3.5 |
| `codeigniter4/framework` | Packagist | All versions | 4.3.5 |
| `codeigniter` | Bitnami | All versions | 4.3.5 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2023-32692?

Upgrade codeigniter4/framework to 4.3.5 or later.

## Is CVE-2023-32692 being exploited?

There is no known exploitation of CVE-2023-32692 in the wild and no public exploit code.

Public exploit code:

- Example application, vulnerable to CVE-2023-32692 (Validation Rule Injection in the PHP Framework CodeIgniter) (github_poc): https://github.com/mogwailabs/CVE-2023-32692-CodeIgniter4

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40827](https://insights.sbomify.com/CVE-2022-40827/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32692 and fix it if it is affected.

What it is: CVE-2023-32692 is a critical code injection vulnerability in CodeIgniter4, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32692 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.3.5
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.3.5
- codeigniter (Bitnami): affected all versions; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32692/ (Markdown: https://insights.sbomify.com/CVE-2023-32692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32692
- OSV: https://osv.dev/vulnerability/CVE-2023-32692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32692/
Summaries are generated and may contain mistakes; the official description above is the record.
