# CVE-2023-32786: Langchain Server-Side Request Forgery vulnerability

> Attackers can exploit prompt injection in Langchain to trigger Server-Side Request Forgery, accessing arbitrary URLs and potentially injecting malicious content.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-6h8p-4hx9-w66c, PYSEC-2026-1508

## What is CVE-2023-32786?

CVE-2023-32786 is a high-severity server-side request forgery vulnerability in n/a, published on 20 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Langchain through 0.0.155, prompt injection allows an attacker to force the service to retrieve data from an arbitrary URL, essentially providing SSRF and potentially injecting content into downstream tasks.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-32786?

3 open source packages ship an affected version, including langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.0.329 |
| `langchain` | PyPI | All versions | 0.0.329 |
| `langchain` | PyPI | All versions | 0.0.329 |

Products: Langchain Langchain.

## How do I fix CVE-2023-32786?

Upgrade langchain to 0.0.329 or later.

## Is CVE-2023-32786 being exploited?

There is no known exploitation of CVE-2023-32786 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-32786 and fix it if it is affected.

What it is: CVE-2023-32786 is a high-severity server-side request forgery vulnerability in n/a, published on 20 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-32786 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.0.329
- langchain (PyPI): affected all versions; fixed in 0.0.329
- langchain (PyPI): affected all versions; fixed in 0.0.329

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-32786/ (Markdown: https://insights.sbomify.com/CVE-2023-32786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-32786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-32786
- OSV: https://osv.dev/vulnerability/CVE-2023-32786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-32786/
Summaries are generated and may contain mistakes; the official description above is the record.
